
SurfacesSurfaces ObjectivesObjectivesSurfaces Surfaces -- ObjectivesObjectives
Cover the Basic DTM Point TypesCover the Basic DTM Point TypesCover the Basic DTM Point TypesCover the Basic DTM Point Types
Creating a new InRoads SurfaceCreating a new InRoads Surface
Surface processing in InRoadsSurface processing in InRoadsSurface processing in InRoads Surface processing in InRoads 
Loading 3D data into a SurfaceLoading 3D data into a Surface
A bit about Surface PropertiesA bit about Surface PropertiesA bit about Surface PropertiesA bit about Surface Properties
Overview of the View Surface commandsOverview of the View Surface commands
A glimpse of the DTM Design/Editing toolsA glimpse of the DTM Design/Editing toolsg p g gg p g g
A bit about earthwork volumesA bit about earthwork volumes
InRoads Locks, … a beginningInRoads Locks, … a beginning
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Digital Terrain ModelsDigital Terrain ModelsDigital Terrain ModelsDigital Terrain Models

Digital Terrain Models are 3Digital Terrain Models are 3--D surfacesD surfaces
Representing:Representing:p gp g

Existing conditionsExisting conditions
Design conditionsDesign conditions

03 Jun 0703 Jun 07© 2007 Zen Engineering / Mark S. Ditko© 2007 Zen Engineering / Mark S. Ditko
Page 3Page 3--22

Surfaces are key to many InRoads operationsSurfaces are key to many InRoads operations



Surface Point TypesSurface Point TypesSurface Point TypesSurface Point Types
The software uses severalThe software uses severalThe software uses several The software uses several 
different types of points:different types of points:

R d i tR d i tRandom points.Random points.
Breakline points.Breakline points.
Interior boundary pointsInterior boundary pointsInterior boundary points.Interior boundary points.
Exterior boundary points.Exterior boundary points.
Contour pointsContour pointsContour points.Contour points.
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Random PointsRandom PointsRandom PointsRandom Points
Random or regular points are singular pointsRandom or regular points are singular pointsRandom, or regular points, are singular points Random, or regular points, are singular points 
with X, Y and Z coordinateswith X, Y and Z coordinates
They have no direct relationship with otherThey have no direct relationship with otherThey have no direct relationship with other They have no direct relationship with other 
points.points.
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BreaklinesBreaklinesBreaklinesBreaklines

B kli d i f d l hB kli d i f d l hBreaklines are used in a surface model where Breaklines are used in a surface model where 
a linear relationship exist along a patha linear relationship exist along a path
T oT o or more points are req ired to define aor more points are req ired to define aTwoTwo or more points are required to define a or more points are required to define a 
breakline.breakline.
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Interior BoundaryInterior BoundaryInterior BoundaryInterior Boundary
Interior boundaries define void areasInterior boundaries define void areas

No computations occur No computations occur insideinside these void areas.these void areas.
Must be a closed figureMust be a closed figure
A single surface can have many Interior BoundariesA single surface can have many Interior Boundaries

Can be collected Can be collected 
around perimeters around perimeters 
of ponds, buildings, of ponds, buildings, 
lakes or inaccessiblelakes or inaccessible areasareaslakes or inaccessible lakes or inaccessible areas.areas.
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Exterior BoundaryExterior BoundaryExterior BoundaryExterior Boundary
Exterior boundary points are used to limit the Exterior boundary points are used to limit the y py p
outer extent of the model.outer extent of the model.

No computations occur No computations occur outsideoutside the exterior limit.the exterior limit.
Only 1 exterior boundary can be defined per model.Only 1 exterior boundary can be defined per model.
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ContoursContoursContoursContours
A contour is a graphic element in which allA contour is a graphic element in which allA contour is a graphic element in which all A contour is a graphic element in which all 
points are at a single elevation.points are at a single elevation.
Contour points are generated from aerialContour points are generated from aerialContour points are generated from aerial Contour points are generated from aerial 
photographs or from existing quadrant maps photographs or from existing quadrant maps 
from the United States Geographical Survey.from the United States Geographical Survey.
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Creating a SurfaceCreating a SurfaceCreating a SurfaceCreating a Surface
First add the ‘components’ that define theFirst add the ‘components’ that define theFirst add the components  that define the First add the components  that define the 
elevational controlselevational controls
Next processing associates and forms theNext processing associates and forms theNext, processing associates and forms the Next, processing associates and forms the 
relationships between all the data contained in relationships between all the data contained in 
the surface modelthe surface model
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Data ConflictsData ConflictsData ConflictsData Conflicts
The InRoads DTM allows onlyThe InRoads DTM allows only oneone Z (elev )Z (elev )The InRoads DTM allows only The InRoads DTM allows only oneone Z (elev.) Z (elev.) 
value for each Xvalue for each X--Y coordinate.Y coordinate.
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Resolving Data ConflictsResolving Data ConflictsResolving Data ConflictsResolving Data Conflicts
InRoads will still ‘autoInRoads will still ‘auto--resolve’ the crossingresolve’ the crossingInRoads will still autoInRoads will still auto resolve  the crossing resolve  the crossing 
breaklines when it triangulatesbreaklines when it triangulates
Another tool has been added to help hereAnother tool has been added to help hereAnother tool has been added to help hereAnother tool has been added to help here
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Opening Existing InRoads FilesOpening Existing InRoads FilesOpening Existing InRoads FilesOpening Existing InRoads Files
SelectSelect Surface (* dtm)Surface (* dtm)Select Select Surface ( .dtm)Surface ( .dtm)
from the from the Files of type:Files of type:
pick box pick box 
The select the surface The select the surface 
that you wish to openthat you wish to open
Fil OFil O i d ti d tFile>OpenFile>Open is used to is used to 
open any existing open any existing 
InRoads data that youInRoads data that youInRoads data that you InRoads data that you 
may havemay have
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New DTM Data ‘holders’New DTM Data ‘holders’New DTM Data holdersNew DTM Data holders
File > NewFile > New calls up a dialog box for the creationcalls up a dialog box for the creationFile > NewFile > New calls up a dialog box for the creation calls up a dialog box for the creation 
of a memory ‘slot’ to store new surface data. of a memory ‘slot’ to store new surface data. 
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Creating a Surface ‘slot’Creating a Surface ‘slot’gg
The The File > NewFile > New is used to create a placeholderis used to create a placeholder

Set the Tab to Set the Tab to SurfaceSurface
Key in the informationKey in the information
ApplyApply ititApplyApply itit
The ‘slot’ is emptyThe ‘slot’ is empty

TypeType setting:setting:TypeType setting:setting:
ExistingExisting
DesignDesign
SubstratumSubstratum
IgnoreIgnore

This setting relates to the End Area VolumesThis setting relates to the End Area Volumes
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This setting relates to the End Area VolumesThis setting relates to the End Area Volumes



Loading Surface DataLoading Surface DataLoading Surface DataLoading Surface Data

InRoads > File > Import >InRoads > File > Import >InRoads > File > Import > InRoads > File > Import > 
Surface...Surface...
File > Text Import WizardFile > Text Import Wizard

ASCII surface informationASCII surface information
… … 
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Loading Graphical DataLoading Graphical DataLoading Graphical DataLoading Graphical Data
From GraphicsFrom Graphics tabtabFrom GraphicsFrom Graphics tabtab

Set the Set the SurfaceSurface
Load From…Load From…
Define the 3 Feature ID’sDefine the 3 Feature ID’s

•• Name (Unique)Name (Unique)
St l (1 t M )St l (1 t M )•• Style (1 to Many)Style (1 to Many)

•• Type (Point definition)Type (Point definition)

Other Data Specific:Other Data Specific:pp
•• Thin SurfaceThin Surface
•• Max Segment LengthMax Segment Length

Point Density IntervalPoint Density Interval
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•• Point Density IntervalPoint Density Interval



Loading ASCII DataLoading ASCII DataLoading ASCII DataLoading ASCII Data

TheThe From ASCIIFrom ASCII tab is replaced by the TIWtab is replaced by the TIWThe The From ASCIIFrom ASCII tab is replaced by the TIWtab is replaced by the TIW
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Loading Graphical Data 2Loading Graphical Data 2Loading Graphical Data 2Loading Graphical Data 2
Advanced technique for graphical importAdvanced technique for graphical importq g p pq g p p
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Triangulate SurfaceTriangulate SurfaceTriangulate SurfaceTriangulate Surface

D fi th d t l ti hi ithi th fD fi th d t l ti hi ithi th fDefines the data relationships within the surface Defines the data relationships within the surface 
modelmodel
SelectSelect Surface >Surface >Select Select Surface >Surface >
Triangulate...Triangulate...
TheThe ExtendedExtendedThe The Extended Extended 
Data ChecksData Checks
option will correctoption will correctoption will correct option will correct 
and report on and report on 
various problems that may be in your surfacevarious problems that may be in your surface
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Lock TriangulationLock Triangulation



Surface PropertiesSurface Properties Main TabMain Tab
NameName

Surface Properties Surface Properties -- Main TabMain Tab
NameName
DescriptionDescription
Ma LengthMa LengthMax LengthMax Length
PreferencePreference
TTTypeType
Data RangeData Range
Data TotalsData Totals
Lock TrianglesLock Triangles
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Feature PropertiesFeature Propertiespp
Feature PropertiesFeature Properties show the complete Feature show the complete Feature 
‘picture’ for the surface‘picture’ for the surfacepicture  for the surfacepicture  for the surface

NameName
DescriptionDescription
StyleStyle
Point TypePoint Type
Point DensityPoint DensityPoint DensityPoint Density
Exclude from Exclude from 
TriangulationTriangulation
Refresh…Refresh…
PrimaryPrimary
SecondarySecondary
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SecondarySecondary



Save SurfaceSave Surface
Saves the point and triangle information fromSaves the point and triangle information from

Save SurfaceSave Surface
Saves the point and triangle information from Saves the point and triangle information from 
the surface.the surface.
To change theTo change theTo change the To change the 
surface to be surface to be 
saved, toggle saved, toggle , gg, gg
to the desired to the desired 
surface name surface name 
at the bottom at the bottom 
of the dialog of the dialog 
boxbox
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box.box.



‘Close’ Data‘Close’ DataClose  DataClose  Data

‘Flush’ a surface from memory‘Flush’ a surface from memoryFlush  a surface from memoryFlush  a surface from memory
You don’t Delete InRoads data anymore, you You don’t Delete InRoads data anymore, you 
‘Close’ it‘Close’ it
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DTMDTM ContentsContentsDTM DTM –– ContentsContents

Digital Terrain Models are composed of:Digital Terrain Models are composed of:
The ‘pieces’ or Features andThe ‘pieces’ or Features andThe pieces  or Features andThe pieces  or Features and
The Triangle network of relationshipsThe Triangle network of relationships

Some surface commands are FeatureSome surface commands are Feature--based based 
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and others are Triangleand others are Triangle--based.based.



View Surface CommandsView Surface CommandsView Surface CommandsView Surface Commands
View Slope

VectorsView Point

View 
Components

Contours Label
Contours

View Surface Features
Vectors

View Single 
Point Elevation

Vi Si l

View Point 
Elevations

Annotate 
Feature

Perimeter

Triangles View Single 
Slope Vector

View Two 

Crossing
Segments Fit Surface

Point Slope

Profiled 
Model

Gridded
Model

Color-Coded
Aspect Elevation

Update 3-D
Plan Surface

Display

View 
Inferred 

Breaklines

View Surface 
Options
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Aspect, Elevation 
& Slope

Display



Dialog Changes #1Dialog Changes #1Dialog Changes #1Dialog Changes #1

Sli ht i l diffSli ht i l diffSlight visual differencesSlight visual differences
View Commands have a View Commands have a 
commoncommon Surface OptionsSurface Optionscommon common Surface OptionsSurface Options
dialogdialog
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Dialog Changes #2Dialog Changes #2Dialog Changes #2Dialog Changes #2

S f th b tt h b d dS f th b tt h b d dSome of the buttons have been removed and Some of the buttons have been removed and 
replaced with rightreplaced with right--clicksclicks
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InRoads LocksInRoads LocksInRoads LocksInRoads Locks

InRoads > Tools > LocksInRoads > Tools > Locksoads oo s oc soads oo s oc s
These Controls regulate the These Controls regulate the 
output, input or processing of output, input or processing of p , p p gp , p p g
certain InRoads commandscertain InRoads commands
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Pen / Pencil LockPen / Pencil LockPen / Pencil LockPen / Pencil Lock

PenPen / / PencilPencil relates to what relates to what 
occurs on later occurs on later rere--displaydisplay of that of that 
I R d itI R d itInRoads itemInRoads item
The CAD package itself does not The CAD package itself does not 

b t thi tti lb t thi tti lcare about this setting, only care about this setting, only 
InRoads.InRoads.
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Pencil SettingPencil SettingPencil SettingPencil Setting

Information displayed is physically written to the Information displayed is physically written to the 
design file, but it is considered a ‘design file, but it is considered a ‘DraftDraft’ version.’ version.

An alignment is written to the design file in ‘Pencil’; the alignment An alignment is written to the design file in ‘Pencil’; the alignment 
is revised in InRoads and then reis revised in InRoads and then re--displayed; the previous graphics displayed; the previous graphics p y ; p g pp y ; p g p
are updated resulting in 1 alignment in the CAD file. are updated resulting in 1 alignment in the CAD file. 
Contours are displayed in ‘Pencil’; revising the DTM in InRoads Contours are displayed in ‘Pencil’; revising the DTM in InRoads 
and reand re--displaying contours will update the current ones resulting in displaying contours will update the current ones resulting in p y g p gp y g p g
1 set of contours written to the CAD file.1 set of contours written to the CAD file.

Use Use PencilPencil to to updateupdate earlier graphical versions earlier graphical versions 
ft difi ti d d di l dft difi ti d d di l d
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after modifications are made and displayed.after modifications are made and displayed.



Pen SettingPen SettingPen SettingPen Setting

Information displayed is physically written to the Information displayed is physically written to the 
design file, and considered ‘design file, and considered ‘FinalFinal’’

An alignment is written to the design file in ‘Pen’; the alignment is An alignment is written to the design file in ‘Pen’; the alignment is 
revised in InRoads and then rerevised in InRoads and then re--displayed; this results in 2displayed; this results in 2revised in InRoads and then rerevised in InRoads and then re--displayed; this results in 2 displayed; this results in 2 
alignments written to the CAD file. alignments written to the CAD file. 
Contours are displayed in ‘Pen’; revising the DTM in InRoads and Contours are displayed in ‘Pen’; revising the DTM in InRoads and 
rere displaying contours results in 2 sets of contours in the CAD filedisplaying contours results in 2 sets of contours in the CAD filerere--displaying contours results in 2 sets of contours in the CAD file.displaying contours results in 2 sets of contours in the CAD file.

Use Use PenPen mode to mode to retainretain earlier graphical versions earlier graphical versions 
after modifications are made and displayed.after modifications are made and displayed.
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after modifications are made and displayed.after modifications are made and displayed.



InRoads LocksInRoads LocksInRoads LocksInRoads Locks

FYIFYI No moreNo more Write LockWrite Lock InRoads is inInRoads is inFYI FYI -- No more No more Write LockWrite Lock, InRoads is in , InRoads is in 
permanent ‘Write Lock on’ modepermanent ‘Write Lock on’ mode

Get used to it, it’s goneGet used to it, it’s gone
Feature Highlight Lock Feature Highlight Lock will highlight the will highlight the 
selected surface feature in the CAD viewselected surface feature in the CAD view
Tool TipTool Tip indicates the position of the lockindicates the position of the lock
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SurfacesSurfaces Summary 1Summary 1Surfaces Surfaces –– Summary 1Summary 1
TheThe 5 DTM Point Types5 DTM Point Types are Randomare Random BreaklineBreaklineThe The 5 DTM Point Types5 DTM Point Types are Random, are Random, BreaklineBreakline, , 
Interior & Exterior Boundaries and ContoursInterior & Exterior Boundaries and Contours
ASCII & GraphicalASCII & Graphical 3D DTM input is common3D DTM input is commonASCII & GraphicalASCII & Graphical 3D DTM input is common3D DTM input is common
TriangulationTriangulation is required to produce a surfaceis required to produce a surface
Surfaces have aSurfaces have a DTMDTM file extensionfile extensionSurfaces have a Surfaces have a .DTM.DTM file extensionfile extension
On On redisplayredisplay, Pen is retained / Pencil is updated, Pen is retained / Pencil is updated
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SurfacesSurfaces Hands onHands onSurfaces Surfaces –– Hands onHands on

Lecture Pause …Lecture Pause …
Start Lab Chapter 2Start Lab Chapter 2 33… Start Lab, Chapter 2… Start Lab, Chapter 2--33

03 Jun 0703 Jun 07© 2007 Zen Engineering / Mark S. Ditko© 2007 Zen Engineering / Mark S. Ditko
Page 3Page 3--3434



Volume MethodsVolume MethodsVolume MethodsVolume Methods
Triangle VolumesTriangle Volumes thetheTriangle VolumesTriangle Volumes -- the the 
precise volume between precise volume between 
any 2 InRoads DTMsany 2 InRoads DTMsany 2 InRoads DTMsany 2 InRoads DTMs
Grid VolumesGrid Volumes -- used to calculate an estimated used to calculate an estimated 
volume between 2 DTMs, or to match calcs made volume between 2 DTMs, or to match calcs made 
against a gridded mass grading planagainst a gridded mass grading plan
EndEnd--Area VolumesArea Volumes -- generates volumes based generates volumes based 

th hi t i ll d ti th dth hi t i ll d ti th don the historically used cross section methodon the historically used cross section method
Triangle Volume by StationTriangle Volume by Station –– Triangle Precision Triangle Precision 
with Endwith End--Area Volume stationing controlArea Volume stationing control (V8 3 only)(V8 3 only)
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with Endwith End Area Volume stationing control Area Volume stationing control (V8.3 only)(V8.3 only)



Triangle VolumesTriangle VolumesTriangle VolumesTriangle Volumes
2 triangulated surfaces are required before2 triangulated surfaces are required before2 triangulated surfaces are required before 2 triangulated surfaces are required before 
calculating triangle volumes calculating triangle volumes (and grid volumes)(and grid volumes)

Triangles are projected between the originalTriangles are projected between the originalTriangles are projected between the original Triangles are projected between the original 
surface and the design surfacesurface and the design surface

The software then forms threeThe software then forms three--sided prismoids sided prismoids pp
from these projectionsfrom these projections

The volume of cut and fill is calculated from The volume of cut and fill is calculated from 
the prismoids.the prismoids.
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Triangle VolumesTriangle VolumesTriangle VolumesTriangle Volumes

3 M d3 M d3 Modes:3 Modes:
Entire SurfaceEntire Surface
Fence / RegionFence / RegionFence / RegionFence / Region
Selected ShapesSelected Shapes

Identify the OriginalIdentify the OriginalIdentify the Original Identify the Original 
Surface & Design SurfaceSurface & Design Surface
CutCut // Fill; ShrinkFill; Shrink // Swell; ExpansionSwell; Expansion // ContractionContractionCutCut / / Fill; ShrinkFill; Shrink / / Swell; ExpansionSwell; Expansion / / Contraction Contraction 
Factors can be used if desiredFactors can be used if desired
Functionality to run multiple volumes at a timeFunctionality to run multiple volumes at a time
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Functionality to run multiple volumes at a time Functionality to run multiple volumes at a time 
has returned to the Triangle Volumeshas returned to the Triangle Volumes



Grid VolumesGrid VolumesGrid VolumesGrid Volumes
Two triangulatedTwo triangulatedTwo triangulated Two triangulated 
DTMs are compared DTMs are compared 
against a grid overlayagainst a grid overlayg g yg g y
CutCut / / Fill is computed Fill is computed 
within each grid cellwithin each grid cell
The size of the grid The size of the grid 
cell is defined by the usercell is defined by the user
The smaller the grid size, the more accurate The smaller the grid size, the more accurate 
the results, but with slower processing.the results, but with slower processing.
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Surface Design CommandsSurface Design CommandsSurface Design CommandsSurface Design Commands

Transverse Transverse 
FeatureFeature

Longitudinal Longitudinal 
FeatureFeature

Apply TemplateApply Template
Set LinearSet Linear
ElevationElevation

FilletFillet
Features Features 

Place Place 
F tF t

Sl dSl d
IsopachIsopach

FeatureFeature

Set SlopeSet Slope SlopedSloped
Surface Surface Project LineProject Line

to Surfaceto Surface
DrapeDrape

SurfaceSurface

Set SlopeSet Slope
AlongAlong
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Feature Editing in PlanFeature Editing in PlanFeature Editing in PlanFeature Editing in Plan

Some Edit tools have Some Edit tools have dialog boxes dialog boxes 
(( means that a dialog box will follow)means that a dialog box will follow)((…… means that a dialog box will follow)means that a dialog box will follow)
Some Edit tools don’t have dialog boxesSome Edit tools don’t have dialog boxes
Watch theWatch the InRoads PromptsInRoads Prompts! (If there! (If thereWatch the Watch the InRoads PromptsInRoads Prompts! (If there ! (If there 
isn’t a dialog box following prompts is isn’t a dialog box following prompts is 
required)required)required)required)
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Edit Surface CommandsEdit Surface CommandsEdit Surface CommandsEdit Surface Commands
R F tR F t D l tD l tDelete FeatureDelete Feature

DivideDivide
FeatureFeature

Edit FeatureEdit Feature
P i tP i t Partial DeletePartial Delete

Reverse Feature Reverse Feature 
DirectionDirection

DeleteDelete
FeatureFeature

Delete FeatureDelete Feature
PointsPoints

PointPoint

Copy SingleCopy Single
FeatureFeature

Partial DeletePartial Delete

Break FeatureBreak Feature

Delete Delete 
TriangleTriangle

FeatureFeature

Join FeatureJoin Feature

E t dE t d TriangleTriangle

TrimTrim
FeaturesFeatures

Merge Merge 
SurfacesSurfaces Transform Transform 

SurfaceSurface

ExtendExtend
FeaturesFeatures Intersect TwoIntersect Two

FeaturesFeatures

Copy Portion of SurfaceCopy Portion of Surface
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FeaturesFeatures Copy Portion of SurfaceCopy Portion of Surface
(Copy Multiple Features)(Copy Multiple Features)



SurfacesSurfaces Summary 2Summary 2Surfaces Surfaces –– Summary 2Summary 2
The The 5 DTM Point Types5 DTM Point Types are Random, are Random, BreaklineBreakline, Interior & Exterior , Interior & Exterior ypyp ,, ,,
Boundaries and ContoursBoundaries and Contours
ASCIIASCII surface data is input with the surface data is input with the Text Import WizardText Import Wizard
TriangulationTriangulation is required to produce a surfaceis required to produce a surfaceTriangulationTriangulation is required to produce a surfaceis required to produce a surface
Lock TriangulationLock Triangulation will not allow the triangles to changewill not allow the triangles to change
Triangle Volumes are able to run Triangle Volumes are able to run multiple volumesmultiple volumes at once and at once and 
require two triangulated surfacesrequire two triangulated surfacesrequire two triangulated surfacesrequire two triangulated surfaces
New tools have been added to assist with crossing New tools have been added to assist with crossing breaklinesbreaklines, , 
elevationalelevational busts and centralized optionsbusts and centralized options
S f hS f h DTMDTM fil t ifil t iSurfaces have a Surfaces have a .DTM.DTM file extensionfile extension
There are a handful of specialized surface There are a handful of specialized surface design toolsdesign tools along with a along with a 
collection of surface collection of surface editing toolsediting tools that work directly with the DTMthat work directly with the DTM
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On On redisplayredisplay, Pen is retained / Pencil is updated, Pen is retained / Pencil is updated


